From: Mel Gorman __GFP_HIGH are used to flag allocations that can access emergency pools. GFP_HIGH_MOVABLE has little to do with __GFP_HIGH and the name is misleading. This patch renames GFP_HIGH_MOVABLE to GFP_HIGHUSER_MOVABLE so that it is clearer. Signed-off-by: Mel Gorman Acked-by: Andy Whitcroft Acked-by: Christoph Lameter Signed-off-by: Andrew Morton --- mm/swap_prefetch.c | 2 +- 1 files changed, 1 insertion(+), 1 deletion(-) diff -puN mm/swap_prefetch.c~rename-gfp_high_movable-to-gfp_highuser_movable-prefetch mm/swap_prefetch.c --- a/mm/swap_prefetch.c~rename-gfp_high_movable-to-gfp_highuser_movable-prefetch +++ a/mm/swap_prefetch.c @@ -208,7 +208,7 @@ static enum trickle_return trickle_swap_ * Get a new page to read from swap. We have already checked the * watermarks so __alloc_pages will not call on reclaim. */ - page = alloc_pages_node(node, GFP_HIGH_MOVABLE & ~__GFP_WAIT, 0); + page = alloc_pages_node(node, GFP_HIGHUSER_MOVABLE & ~__GFP_WAIT, 0); if (unlikely(!page)) { ret = TRICKLE_DELAY; goto out; _